Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain a shell remotely >> OpenSSL overflow via invalid certificate passing


Vulnerability Assessment Details

OpenSSL overflow via invalid certificate passing

Vulnerability Assessment Summary
Checks for the behavior of SSL

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote host is vulnerable to a heap corruption vulnerability.

Description :

The remote host seems to be running a version of OpenSSL which is older
than 0.9.6k or 0.9.7c.

There is a heap corruption bug in this version which might be exploited by an
attacker to execute arbitrary code on the remote host with the rights
of the remote service.

Solution :

If you are running OpenSSL, upgrade to version 0.9.6k or 0.9.7c or newer.

Network Security Threat Level:

Critical / CVSS Base Score : 10
(AV:R/AC:L/Au:NR/C:C/A:C/I:C/B:N)

Networks Security ID: 8732, 13359

Vulnerability Assessment Copyright: This script is Copyright (C) 2003-2006 Tenable Network Security

Cables, Connectors

NETGEAR JGS524NA ProSafe 24 Port Gigabit Rackmount Switch
$74.99
NETGEAR JGS524NA ProSafe 24 Port Gigabit Rackmount Switch pictureMulti Link PolNet 5 Port Network Modem Switch Fax Phone Call Router Out of Band
$310.95
Multi Link PolNet 5 Port Network Modem Switch Fax Phone Call Router Out of Band pictureZyXEL - GS1100-24E 24-Port 10/100/1000
$100.04
ZyXEL - GS1100-24E 24-Port 10/100/1000 pictureHikvision DS-3E0105P-E 4-ports 100Mbps Unmanaged Power over Ethernet PoE Switch
$49.5
Hikvision DS-3E0105P-E 4-ports 100Mbps Unmanaged Power over Ethernet PoE Switch picture


Discussions

No Discussions have been posted on this vulnerability.