Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Moodle SQL injection flaws


Vulnerability Assessment Details

Moodle SQL injection flaws

Vulnerability Assessment Summary
Acertains if Moodle is older than 1.4.3

Detailed Explanation for this Vulnerability Assessment

The remote host is running a version of the Moodle suite, an open-source
course management system written in PHP, which is older than version 1.4.3.

The remote version of this software is vulnerable to SQL injection issue
in 'glossary' module due to a lack of user input sanitization.

Solution : Upgrade to Moodle 1.4.3 or later.
Network Security Threat Level: High

Networks Security ID: 11608, 11691, 12120

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 David Maciejak

Cables, Connectors

Jim Stone Conspiracy Files 4 - Knoppix 8.1 live DVD and SD
$200.0
Jim Stone Conspiracy Files 4 - Knoppix 8.1 live DVD and SD pictureJim Stone Conspiracy Files 4 - Knoppix 8.1 live copy 20
$30.0
Jim Stone Conspiracy Files 4 - Knoppix 8.1 live copy 20 pictureJim Stone Conspiracy Files 4 - Knoppix 8.1 live copy 18
$30.0
Jim Stone Conspiracy Files 4 - Knoppix 8.1 live copy 18 pictureJim Stone Conspiracy Files 4 - Knoppix 8.1 live copy 15
$100.0
Jim Stone Conspiracy Files 4 - Knoppix 8.1 live copy 15 picture


Discussions

No Discussions have been posted on this vulnerability.