Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gentoo Local Security Checks >> [GLSA-200508-17] libpcre: Heap integer overflow


Vulnerability Assessment Details

[GLSA-200508-17] libpcre: Heap integer overflow

Vulnerability Assessment Summary
libpcre: Heap integer overflow

Detailed Explanation for this Vulnerability Assessment
The remote host is affected by the vulnerability described in GLSA-200508-17
(libpcre: Heap integer overflow)


libpcre fails to check certain quantifier values in regular
expressions for sane values.

Impact

A possible hacker could possibly exploit this vulnerability to execute
arbitrary code by sending specially crafted regular expressions to
applications making use of the libpcre library.

Workaround

There is no known workaround at this time.

References:
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-2491
http://www.securitytracker.com/alerts/2005/Aug/1014744.html


Solution:
All libpcre users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/libpcre-6.3"


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: (C) 2005 Michel Arboi

Cables, Connectors

HP ProLiant DL360 G7 Server 2x 2.66GHz Intel Xeon X5650 Six Core 64Gb 2x 300Gb
$365.0
HP ProLiant DL360 G7 Server 2x 2.66GHz Intel Xeon X5650 Six Core 64Gb 2x 300Gb pictureDell PowerEdge R610 2x X5660 2.8GHz 6 Core 96GB 6x 600GB 10K SAS PERC 6/i
$1630.0
Dell PowerEdge R610 2x X5660 2.8GHz 6 Core 96GB 6x 600GB 10K SAS PERC 6/i pictureDell PowerEdge R510 2x L5640 2.26GHz 6 Core 64GB 12x 3TB 7.2K SAS PERC H700
$2585.0
Dell PowerEdge R510 2x L5640 2.26GHz 6 Core 64GB 12x 3TB 7.2K SAS PERC H700 pictureLENOVO THINKSERVER RD650 E5-2680V4 2.4GHZ 32GB 800GB SSD
$3429.0
LENOVO THINKSERVER RD650 E5-2680V4 2.4GHZ 32GB 800GB SSD picture


Discussions

No Discussions have been posted on this vulnerability.