Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Debian Local Security Checks >> [DSA976] DSA-976-1 libast


Vulnerability Assessment Details

[DSA976] DSA-976-1 libast

Vulnerability Assessment Summary
DSA-976-1 libast

Detailed Explanation for this Vulnerability Assessment

Johnny Mast discovered a buffer overflow in libast, the library of
assorted spiffy things, that can lead to the execution of arbitrary
code. This library is used by eterm which is installed setgid uid
which leads to a vulnerability to alter the utmp file.
For the old stable distribution (woody) this problem has been fixed in
version 0.4-3woody2.
For the stable distribution (sarge) this problem has been fixed in
version 0.6-0pre2003010606sarge1.
For the unstable distribution (sid) this problem will be fixed soon.
We recommend that you upgrade your libast packages.


Solution : http://www.debian.org/security/2006/dsa-976
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is (C) 2006 Michel Arboi

Cables, Connectors

Hitachi DeskStar 80Gb 3.5in SATA Hard Disk Drive 0A31048 HDS728080PLA380
$16.25
Hitachi DeskStar 80Gb 3.5in SATA Hard Disk Drive 0A31048 HDS728080PLA380 pictureWestern Digital - WD5000LPLX - 500GB - 2.5" Drive - 7mm height
$33.0
Western Digital - WD5000LPLX - 500GB - 2.5Western Digital,400GB, SATA, WD4000AAJS-00YFA0
$24.74
Western Digital,400GB, SATA, WD4000AAJS-00YFA0 pictureWestern Digital WD Caviar WD400BB-75CAA0 40GB 7200RP Hard Drive
$16.25
Western Digital WD Caviar WD400BB-75CAA0 40GB 7200RP Hard Drive picture


Discussions

No Discussions have been posted on this vulnerability.