Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> AppServ appserv_root Parameter Remote File Include Vulnerability


Vulnerability Assessment Details

AppServ appserv_root Parameter Remote File Include Vulnerability

Vulnerability Assessment Summary
Checks for appserv_root parameter remote file include vulnerability in AppServ

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server is prone to a remote file inclusion
vulnerability.

Description :

The remote host appears to be running AppServ, a compilation of
Apache, PHP, MySQL, and phpMyAdmin for Windows and Linux.

The version of AppServ installed on the remote host fails to sanitize
user-supplied input to the 'appserv_root' parameter of the
'appserv/main.php' script before using it in a PHP 'include' function.
An unauthenticated attacker can exploit this flaw to run arbitrary
code, possibly taken from third-party hosts, subject to the rights
of the web server user id. Note that AppServ under Windows runs with
SYSTEM rights, which means a possible hacker can gain complete control
of the affected host.

Solution :

Unknown at this time.

Network Security Threat Level:

Low / CVSS Base Score : 2.3
(AV:R/AC:L/Au:NR/C:N/I:P/A:N/B:N)

Networks Security ID: 16166

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

Lot 2 HP BladeSystem C7000 Blade Server Chassis 403323-B23 w/ Fans
$40.0
Lot 2 HP BladeSystem C7000 Blade Server Chassis 403323-B23 w/ Fans  pictureHP PROLIANT BL460C G8 2 X QUAD CORE 2.40GHZ E5-2609 BLADE NO MEMORY/NO HD AA002
$95.0
HP PROLIANT BL460C G8 2 X QUAD CORE 2.40GHZ E5-2609 BLADE NO MEMORY/NO HD AA002 pictureHP PROLIANT BL460C G8 2 X QUAD CORE 2.40GHZ E5-2609 BLADE NO MEMORY/NO HD AA234
$95.0
HP PROLIANT BL460C G8 2 X QUAD CORE 2.40GHZ E5-2609 BLADE NO MEMORY/NO HD AA234 pictureHP PROLIANT BL460C G8 2 X QUAD CORE 2.40GHZ E5-2609 BLADE NO MEMORY/NO HD
$95.0
HP PROLIANT BL460C G8 2 X QUAD CORE 2.40GHZ E5-2609 BLADE NO MEMORY/NO HD picture


Discussions

No Discussions have been posted on this vulnerability.