Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> phpMyAdmin arbitrary files reading


Vulnerability Assessment Details

phpMyAdmin arbitrary files reading

Vulnerability Assessment Summary
Searches for the existence of sql.php

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP script that is affected by a
local file inclusion flaw.

Description :

It is possible to make the remote phpMyAdmin installation read
arbitrary data on the remote host. A possible hacker may use this flaw to
read arbitrary files that your web server has the right to access or
execute arbitrary PHP code.

See also :

http://archives.neohapsis.com/archives/bugtraq/2001-04/0396.html

Solution :

Upgrade to phpMyAdmin 2.2.1 or newer

Network Security Threat Level:

Medium / CVSS Base Score : 6
(AV:R/AC:H/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID: 2642

Vulnerability Assessment Copyright: This script is Copyright (C) 2002-2007 Renaud Deraison

Cables, Connectors

RARE Alienware M17x Laptop Radeon HD 3870 P8400 Core 2 duo 2.26GHz 80GB 4GB RAM
$245.0
RARE Alienware M17x Laptop Radeon HD 3870 P8400 Core 2 duo 2.26GHz 80GB 4GB RAM pictureDell Latitude 3340 Laptop Intel Core i3 1.7GHz 8GB Ram 500GB HDD Windows 10 Pro
$169.99
Dell Latitude 3340 Laptop Intel Core i3 1.7GHz 8GB Ram 500GB HDD Windows 10 Pro pictureBarrette RAM RAM DDR2 1gb 1Gb for hp Compaq 8510p
$5.97
Barrette RAM RAM DDR2 1gb 1Gb for hp Compaq 8510p pictureBarrette RAM RAM DDR3 4gb 4Gb Acer Aspire 5551G
$120.47
Barrette RAM RAM DDR3 4gb 4Gb Acer Aspire 5551G picture


Discussions

No Discussions have been posted on this vulnerability.