Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> phpBB Fetch All < 2.0.12


Vulnerability Assessment Details

phpBB Fetch All < 2.0.12

Vulnerability Assessment Summary
Check for phpBB Fetch All version

Detailed Explanation for this Vulnerability Assessment

The remote host is running a version of phpBB FetchAll older than 2.0.12.

It is reported that this version of phpBB Fetch All is susceptible
to an SQL injection vulnerability. This issue is due to a failure of
the application to properly sanitize user-supplied input before using
it in an SQL query.

The successful exploitation of this vulnerability depends on the
implementation of the web application that includes phpBB Fetch All
as a component. It may or may not be possible to effectively pass
malicious SQL statements to the underlying function.

Successful exploitation could result in compromise of the application,
disclosure or modification of data or may permit a possible hacker to exploit
vulnerabilities in the underlying database implementation.


Solution : Upgrade to phpBB Fetch All 2.0.12 or later
Network Security Threat Level: High

Networks Security ID: 10868, 10893

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 David Maciejak

Cables, Connectors

AMD RYZEN 7 1700X 8-CORE GAMING PC GTX 1660Ti✔ 16GB RAM ✔ 256GB M.2 SSD+2TB HD ✔
$1039.0
AMD RYZEN 7 1700X 8-CORE GAMING PC GTX 1660Ti✔ 16GB RAM ✔ 256GB M.2 SSD+2TB HD ✔ picture Apple Late 2013 Mac Pro 3GHz 8 Core/64 GB RAM/1 TB Flash/ D700
$2700.0
 Apple Late 2013 Mac Pro 3GHz 8 Core/64 GB RAM/1 TB Flash/ D700 pictureHP Proliant DL360p G8 Server-2x E5-2680 8 Core 2.7GHz-128GB-4x 300GB 15K-4x 1TB
$1558.9
HP Proliant DL360p G8 Server-2x E5-2680 8 Core 2.7GHz-128GB-4x 300GB 15K-4x 1TB pictureHP Proliant DL360p G8 Server-2x E5-2680 8 Core 2.7GHz-128GB-4x 300GB 15K-P420 2G
$1246.38
HP Proliant DL360p G8 Server-2x E5-2680 8 Core 2.7GHz-128GB-4x 300GB 15K-P420 2G picture


Discussions

No Discussions have been posted on this vulnerability.