Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> php4/5 Vulnerabilities


Vulnerability Assessment Details

php4/5 Vulnerabilities

Vulnerability Assessment Summary
Checks for version of PHP

Detailed Explanation for this Vulnerability Assessment

The remote host is running a version of PHP which is older than 5.0.3 or
4.3.10.

The remote version of this software is vulnerable to various security
issues which may, under certain circumstances, to execute arbitrary code
on the remote host, provided that we can pass arbitrary data to some
functions, or to bypass safe_mode.

See also : http://www.php.net/ChangeLog-5.php#5.0.3
Solution : Upgrade to PHP 5.0.3 or 4.3.10
Network Security Threat Level: High

Networks Security ID: 11964, 11981, 11992, 12045

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

5 x KNOPPIX LINUX v. 8.2 DVD & 16GB USB 3.0 Flash Drive + Persistence Mode
$99.99
5 x KNOPPIX LINUX v. 8.2 DVD & 16GB USB 3.0 Flash Drive + Persistence Mode pictureKnoppix 7.2.0 Live Linux Bootable Startup CD (Runs form CD) +Free Retro Linux CD
$11.95
Knoppix 7.2.0 Live Linux Bootable Startup CD (Runs form CD) +Free Retro Linux CD pictureKnoppix 8.2
$4.99
Knoppix 8.2 pictureKNOPPIX 8.1 LINUX LIVE DVD - 2018
$5.95
KNOPPIX 8.1 LINUX LIVE DVD - 2018 picture


Discussions

No Discussions have been posted on this vulnerability.