Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> myServer 0.4.3 / 0.7 Directory Traversal Vulnerability


Vulnerability Assessment Details

myServer 0.4.3 / 0.7 Directory Traversal Vulnerability

Vulnerability Assessment Summary
Attempts to retrieve the path '/././..'

Detailed Explanation for this Vulnerability Assessment

This web server is running myServer <= 0.4.3 or 0.7. This version contains
a directory traversal vulnerability, that permits remote users with
no authentication to read files outside the webroot.

You have to create a dot-dot URL with the same number of '/./' and '/../'
+ 1. For example, you can use :
/././..
/./././../..
/././././../../..
/./././././../../../..
etc...
or a long URL starting with ./././. etc.

More information : http://www.securityfocus.com/archive/1/339145

Solution : Upgrade to myServer 0.7.1 or later
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: Author Paul Johnston paul@westpoint.ltd.uk, Copyright (C) 2003 Westpoint Ltd

Cables, Connectors

KNOPPIX LINUX 8.2.0 64 Bit Live Install FAST 3.0 Bootable USB
$4.99
KNOPPIX LINUX 8.2.0 64 Bit Live Install FAST 3.0 Bootable USB pictureKNOPPIX LINUX 8.2.0 64 Bit Live Install FAST 3.0 Bootable USB
$4.99
KNOPPIX LINUX 8.2.0 64 Bit Live Install FAST 3.0 Bootable USB pictureKNOPPIX LINUX 8.2.0 64 Bit Live Install FAST 3.0 Bootable USB
$14.94
KNOPPIX LINUX 8.2.0 64 Bit Live Install FAST 3.0 Bootable USB pictureKNOPPIX LINUX 8.2.0 64 Bit Live Install FAST 3.0 Bootable USB
$19.94
KNOPPIX LINUX 8.2.0 64 Bit Live Install FAST 3.0 Bootable USB picture


Discussions

No Discussions have been posted on this vulnerability.