Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> eFiction < 2.0.2 Multiple Vulnerabilities


Vulnerability Assessment Details

eFiction < 2.0.2 Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks for multiple vulnerabilities in eFiction < 2.0.2

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server has a PHP application that is affected by
multiple flaws.

Description :

The remote host is running eFiction, an open-source application in PHP
for writers.

The installed version of eFiction is affected by numerous flaws :

- Members may be able to upload files containing arbitrary
PHP code disguised as image files and then run that code
on the remote host subject to the rights of the web
server user id. If a possible hacker does not yet have access,
he can register and have a password mailed to him
automatically.

- User-supplied input to several parameters and scripts is
used without sanitation, which can lead to SQL injection
attacks provided PHP's 'magic_quotes_gpc' is disabled.
These issues can be exploited, for example, to bypass
authentication or disclose sensitive information.

- User-supplied input to the 'let' parameter of the
'titles.php' script is not sanitized before being used
in dynamically-generated web pages, which leads to
cross-site scripting attacks.

- An unauthenticated attacker may be able to gain
information about the installation and configuration of
PHP on the remote host by requesting the 'phpinfo.php'
script or to learn the install path by a direct request
to the 'storyblock.php' script with no arguments.

- Unauthenticated attackers may be able to access the
'install.php' and/or 'upgrade.php' scripts and thereby
modify the installation on the remote host.

See also :

http://retrogod.altervista.org/efiction2_xpl.html
http://archives.neohapsis.com/archives/bugtraq/2005-11/0301.html
http://efiction.wallflowergirl.com/forums/viewtopic.php?t=1553

Solution :

Upgrade to eFiction 2.0.2 or later.

Network Security Threat Level:

High / CVSS Base Score : 7.0
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 15568

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

Dell PowerEdge R720xd 2x E5-2640 v2 2.0GHz 8 Core 192GB 12x 1TB 7.2K SATA H710P
$3750.0
Dell PowerEdge R720xd 2x E5-2640 v2 2.0GHz 8 Core 192GB 12x 1TB 7.2K SATA H710P pictureHP ProLiant DL380 G7 2x X5650 2.66GHz 6 Core 72GB 8x 300GB 15K SAS P410i 512MB
$3402.0
HP ProLiant DL380 G7 2x X5650 2.66GHz 6 Core 72GB 8x 300GB 15K SAS P410i 512MB pictureDell PowerEdge R720xd 2x E5-2620 2.0GHz 6 Core 16GB 12x 600GB 15K SAS H710P
$3890.0
Dell PowerEdge R720xd 2x E5-2620 2.0GHz 6 Core 16GB 12x 600GB 15K SAS H710P pictureHP ProLiant DL380 G7 2x X5650 2.66GHz 6 Core 144GB 8x 146GB 15K SAS P410i 512MB
$2088.07
HP ProLiant DL380 G7 2x X5650 2.66GHz 6 Core 144GB 8x 146GB 15K SAS P410i 512MB picture


Discussions

No Discussions have been posted on this vulnerability.