Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Ultimate PHP Board admin_ip.php code injection


Vulnerability Assessment Details

Ultimate PHP Board admin_ip.php code injection

Vulnerability Assessment Summary
Checks for UPB

Detailed Explanation for this Vulnerability Assessment

The remote host is running Ultimate PHP Board (UPB).

There is a flaw in this version which may permit a possible hacker
to execute arbitrary code on this host, by sending a malformed
user-agent which contains PHP commands. Once the user-agent
has been sent, it is stored in the logs. When the administrator
of this web site will read the logs through admin_ip.php,
the code will be executed.

Solution : Upgrade to the latest version of this CGI
Network Security Threat Level: High

Networks Security ID: 7678

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Renaud Deraison

Cables, Connectors

Supermicro Intel C222 Socket H3 Micro ATX Server Motherboard MBD-X10SLL-F-O
$174.42
Supermicro Intel C222 Socket H3 Micro ATX Server Motherboard MBD-X10SLL-F-O pictureNEW HPE 819187-001 ProLiant MicroServer Gen8 E3-1220Lv2 1P 4GBU B120i NHP SATA
$721.98
NEW HPE 819187-001 ProLiant MicroServer Gen8 E3-1220Lv2 1P 4GBU B120i NHP SATA pictureNEW HPE 819185-001 ProLiant MicroServer Gen8 G1610T 1P 4GB-U B120i Non-hot Plug
$436.98
NEW HPE 819185-001 ProLiant MicroServer Gen8 G1610T 1P 4GB-U B120i Non-hot Plug pictureNEW HPE 783959-S01 ProLiant MicroServer Gen8 E3-1220v2 8GB-U B120i LFF 4x1TB
$863.98
NEW HPE 783959-S01 ProLiant MicroServer Gen8 E3-1220v2 8GB-U B120i LFF 4x1TB picture


Discussions

No Discussions have been posted on this vulnerability.