Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN54-1 : tiff vulnerability


Vulnerability Assessment Details

USN54-1 : tiff vulnerability

Vulnerability Assessment Summary
tiff vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- libtiff-tools
- libtiff4
- libtiff4-dev


Description :

Dmitry V. Levin discovered a buffer overflow in the "tiffdump"
utility. If a possible hacker tricked a user into processing a malicious
TIFF image with tiffdump, they could cause a buffer overflow which at
least causes the program to crash. However, it is not entirely clear
whether this can be exploited to execute arbitrary code with the
rights of the user opening the image.

Solution :

Upgrade to :
- libtiff-tools-3.6.1-1.1ubuntu1.2 (Ubuntu 4.10)
- libtiff4-3.6.1-1.1ubuntu1.2 (Ubuntu 4.10)
- libtiff4-dev-3.6.1-1.1ubuntu1.2 (Ubuntu 4.10)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

Vintage Apple II Plus Motherboard with 16K Memory Expansion Card
$89.95
Vintage Apple II Plus Motherboard with 16K Memory Expansion Card picture LAPTOP HP G60 , 2GG ,
$40.0
 LAPTOP HP G60  , 2GG ,  picturePro Comp Slot 1 System Board (B680/683)
$38.8
Pro Comp Slot 1 System Board (B680/683) pictureDell Poweredge 400SC System Motherboard Mainboard with Tray F1425
$39.99
Dell Poweredge 400SC System Motherboard Mainboard with Tray F1425 picture


Discussions

No Discussions have been posted on this vulnerability.