Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN156-1 : tiff vulnerability


Vulnerability Assessment Details

USN156-1 : tiff vulnerability

Vulnerability Assessment Summary
tiff vulnerability

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- libtiff-tools
- libtiff4
- libtiff4-dev


Description :

Wouter Hanegraaff discovered that the TIFF library did not
sufficiently validate the "YCbCr subsampling" value in TIFF image
headers. Decoding a malicious image with a zero value resulted in an
arithmetic exception, which caused the program that uses the TIFF
library to crash. This leads to a Denial of Service in server
applications that use libtiff (like the CUPS printing system) and can
cause data loss in, for example, the Evolution email client.

Solution :

Upgrade to :
- libtiff-tools-3.6.1-5ubuntu0.2 (Ubuntu 5.04)
- libtiff4-3.6.1-5ubuntu0.2 (Ubuntu 5.04)
- libtiff4-dev-3.6.1-5ubuntu0.2 (Ubuntu 5.04)



Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

IBM 3693 SAS (YO) Cable Assembly 19.6ft z7
$150.0
IBM 3693 SAS (YO) Cable Assembly 19.6ft z7 pictureNEW Lot of 5 IBM 26K4768 X346 25R5168 Fan Assembly Hot Swap Server Fan
$39.98
NEW Lot of 5 IBM 26K4768 X346 25R5168 Fan Assembly Hot Swap Server Fan pictureHP Compaq PS-3381-1C1 313299-001 (194989-002) 400W Server Power Supply
$13.75
HP Compaq PS-3381-1C1 313299-001 (194989-002) 400W Server Power Supply picture# IBM eServer xSeries 345 Dual Xeon 2.8GHz 1.5GB 8670-L1X
$99.99
# IBM eServer xSeries 345 Dual Xeon 2.8GHz 1.5GB 8670-L1X picture


Discussions

No Discussions have been posted on this vulnerability.