Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Ubuntu Local Security Checks >> USN147-2 : php4, php4-universe fixed packages


Vulnerability Assessment Details

USN147-2 : php4, php4-universe fixed packages

Vulnerability Assessment Summary
php4, php4-universe fixed packages

Detailed Explanation for this Vulnerability Assessment

Summary :

These remote packages are missing security patches :
- libapache-mod-php4
- libapache2-mod-php4
- php4
- php4-cgi
- php4-curl
- php4-dev
- php4-domxml
- php4-gd
- php4-imap
- php4-ldap
- php4-mcal
- php4-mhash
- php4-mysql
- php4-odbc
- php4-pear
- php4-recode
- php4-snmp
- php4-sybase
- php4-universe-common
- php4-xslt


Description :

USN-147-1 [1] fixed a remote code execution vulnerability in the
XMLRPC module of the PEAR library. Unfortunately the packages
announced in USN-147-1 were faulty and shipped broken xmlrpc modules.
The updated packages ship correct modules.

We apologize for the inconvenience.

[1] https://www.ubuntulinux.org/support/documentation/usn/usn-147-1

Solution :

Upgrade to :
- libapache-mod-php4-4.3.10-10ubuntu3.2 (Ubuntu 5.04)
- libapache2-mod-php4-4.3.8-3ubuntu7.10 (Ubuntu 4.10)
- php4-4.3.8-3ubuntu7.10 (Ubuntu 4.10)
- php4-cgi-4.3.8-3ubuntu7.10 (Ubuntu 4.10)
- php4-curl-4.3.10-10ubuntu3.2 (Ubuntu 5.04)
- php4-dev-4.3.8-3ubuntu7.10 (Ubuntu 4.10)
- php4-domxml-4.3.10-10ubuntu3.2 (Ubuntu 5.04)
- php4-gd-4.3.10-10ubuntu3.2 (Ubuntu 5.04)
- php4-imap-4.3.10-10ubuntu3.2 (Ubuntu 5.04)
- php4-ldap-4.3.10-10ubuntu3.2 (Ubuntu 5.04)
- php4-mcal-4.3.10-10ubuntu3.2 (Ubuntu
[...]


Network Security Threat Level: High


Networks Security ID:

Vulnerability Assessment Copyright: Ubuntu Security Notice (C) 2005 Canonical, Inc. / NASL script (C) 2005 Michel Arboi

Cables, Connectors

2014 Dell PowerEdge R220 Intel Xeon E3-1241v3 3.4Ghz Quad 16GB DDR3, 2x1TB SATA
$281.0
2014 Dell PowerEdge R220 Intel Xeon  E3-1241v3 3.4Ghz Quad 16GB DDR3, 2x1TB SATA pictureDell Railkit P/N: WC364 Rackmount Server Rail Kit for Dell PowerEdge Servers
$50.0
Dell Railkit P/N: WC364 Rackmount Server Rail Kit for Dell PowerEdge Servers pictureDell PowerEdge R730XD 2x E5-2678v3 2.5GHz 12C 512GB 20x 900GB 12Gb 15K+ 4x 1.6TB
$14800.0
Dell PowerEdge R730XD 2x E5-2678v3 2.5GHz 12C 512GB 20x 900GB 12Gb 15K+ 4x 1.6TB pictureDell PowerEdge R730 8xSFF 2 x E5-2630v3, 32GB RAM, 2 x 300GB HDD, RAID, Power
$1240.0
Dell PowerEdge R730 8xSFF 2 x E5-2630v3, 32GB RAM, 2 x 300GB HDD, RAID, Power picture


Discussions

No Discussions have been posted on this vulnerability.