Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Trend Micro ServerProtect for Linux splx_2376_info Cookie Authentication Bypass Vulnerability


Vulnerability Assessment Details

Trend Micro ServerProtect for Linux splx_2376_info Cookie Authentication Bypass Vulnerability

Vulnerability Assessment Summary
Tries to bypass authentication with SPLX

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server suffers from an authentication bypass
vulnerability.

Description :

The remote host is running ServerProtect for Linux, an anti-virus
application for Linux-based servers from Trend Micro.

The version of ServerProtect for Linux installed on the remote host
fails to check the validity of the session id in the 'splx_2376_info'
cookie before granting access to its administrative pages. A remote
attacker can exploit this flaw to bypass authentication and gain full
control of the affected web application.

See also :

http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=477
http://www.securityfocus.com/archive/1/460805/30/0/threaded
http://www.trendmicro.com/download/product.asp?productid=20

Solution :

Apply the appropriate patch referenced in the vendor advisory above.

Network Security Threat Level:

High / CVSS Base Score : 7.0
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 22662

Vulnerability Assessment Copyright: This script is Copyright (C) 2007 Tenable Network Security

Cables, Connectors

Supermicro X9DRi-F Dual Xeon LGA2011 EATX Motherboard 3x PCI-E 16x, 2xGBe IPMI
$181.0
Supermicro X9DRi-F Dual Xeon LGA2011 EATX Motherboard 3x PCI-E 16x, 2xGBe IPMI pictureHPE HP DL380 G9 Gen9 SERVER TWO E5-2609V4 1.7GHZ 768GB 3 X 480GB SSD
$12449.0
HPE HP DL380 G9 Gen9 SERVER TWO E5-2609V4 1.7GHZ 768GB 3 X 480GB SSD pictureHPE HP DL380 G9 Gen9 SERVER E5-2680V4 2.4GHZ 48GB 146GB 15K
$3389.0
HPE HP DL380 G9 Gen9 SERVER E5-2680V4 2.4GHZ 48GB 146GB 15K pictureDELL POWEREDGE M630 TWO E5-2620V4 2.1GHZ 128GB 1.8TB 10K 12G H730P
$2959.0
DELL POWEREDGE M630 TWO E5-2620V4 2.1GHZ 128GB 1.8TB 10K 12G H730P picture


Discussions

No Discussions have been posted on this vulnerability.