Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Tomcat 4.x JSP Source Exposure


Vulnerability Assessment Details

Tomcat 4.x JSP Source Exposure

Vulnerability Assessment Summary
Tomcat 4.x JSP Source Exposure

Detailed Explanation for this Vulnerability Assessment

Tomcat 4.0.4 and 4.1.10 (probably all other
earlier versions also) are vulnerable to source
code exposure by using the default servlet
org.apache.catalina.servlets.DefaultServlet.

Solution: Upgrade to the last releases 4.0.5 and 4.1.12.
See http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/
for the last releases.

Network Security Threat Level: High

Networks Security ID: 5786

Vulnerability Assessment Copyright: This script is Copyright (C) 2002 Felix Huber

Cables, Connectors

ALLWORX 9212L VOIP PHONE WITH POWER OVER ETHERNET (POE)
$9.99
ALLWORX 9212L VOIP PHONE WITH POWER OVER ETHERNET (POE)  pictureAdtran Netvanta 6240 Voip Gateway - VLAN - NAt - VQM - CLI - AOS - Quad T1
$239.99
Adtran Netvanta 6240 Voip Gateway - VLAN - NAt - VQM - CLI - AOS - Quad T1  pictureOOMA OFFICE + EXTRA LINX, VOIP SYSTEM + 1 MONTH FREE SERVICE  Free activation
$59.99
OOMA OFFICE + EXTRA LINX, VOIP SYSTEM + 1 MONTH FREE SERVICE  Free activation pictureGrandstream DP750 DECT VoIP Base Station Black
$49.69
Grandstream DP750 DECT VoIP Base Station Black picture


Discussions

No Discussions have been posted on this vulnerability.