Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> Samba trans2open buffer overflow


Vulnerability Assessment Details

Samba trans2open buffer overflow

Vulnerability Assessment Summary
overflows the remote samba server

Detailed Explanation for this Vulnerability Assessment

The remote Samba server is vulnerable to a buffer overflow
when it processes the function trans2open().

A possible hacker may exploit this flaw to gain a root shell on
this host.

Solution : upgrade to Samba 2.2.8a or 3.0.0
Network Security Threat Level: High

Networks Security ID: 7294, 7295

Vulnerability Assessment Copyright: This script is Copyright (C) 2003-2006 Tenable Network Security

Cables, Connectors

16GB DELL A5940906 PC3-12800R for Poweredge Servers
$73.4
16GB DELL A5940906 PC3-12800R for Poweredge Servers picture64GB (4x16GB) DELL A5940906 PC3-12800R for Poweredge Servers
$293.57
64GB (4x16GB) DELL A5940906 PC3-12800R for Poweredge Servers pictureDELL NETWORKING N3048 - SWITCH - 48 PORTS - MANAGED - RACK-MOUNTABLE
$2499.99
DELL NETWORKING N3048 - SWITCH - 48 PORTS - MANAGED - RACK-MOUNTABLE pictureDELL NETWORKING N3048 - SWITCH - 48 PORTS - MANAGED - RACK-MOUNTABLE
$3049.99
DELL NETWORKING N3048 - SWITCH - 48 PORTS - MANAGED - RACK-MOUNTABLE picture


Discussions

No Discussions have been posted on this vulnerability.