Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> SuSE Local Security Checks >> SUSE-SA:2003:016: samba, samba-client


Vulnerability Assessment Details

SUSE-SA:2003:016: samba, samba-client

Vulnerability Assessment Summary
Check for the version of the samba, samba-client package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory SUSE-SA:2003:016 (samba, samba-client).



Sebastian Krahmer, SUSE Security Team, reviewed security-critical
parts of the Samba server within the scope of security audits that
the SUSE Security Team conducts on a regular basis for security-critical
Open Source Software.
Buffer overflows and a chown race condition have been discovered and
fixed during the security audit. The buffer overflow vulnerabilitiy
permits a remote attacker to execute arbitrary commands as root on the
system running samba. In addition to the flaws fixed in the samba
server, some overflow conditions in the samba-client package have
been fixed with the available update packages. It is strongly
recommended to install the update packages on a system where the
samba package is used.

There exists no temporary workaround against this vulnerability other
than shutting down the smbd daemon.

We would like to thank the Samba Team, especially Jeremy Allison, Andrew
Bartlett and Volker Lendecke for their quick response and cooperation.

Please note that the package names for SUSE products vary for different
products. There exist the following pairings:
server client
----------------------------
samba smbclnt
samba samba-client
samba-classic samba-classic-client
samba-ldap samba-ldap-client

To find out which packages are installed on your system, you may run
the following command:

rpm -qa|egrep '(samba|smbclnt)'

Please download the update package for your distribution and verify its
integrity by the methods listed in section 3) of this announcement.
Then, install the package using the command 'rpm -Fhv file.rpm' to apply
the update.

Solution : http://www.suse.de/security/2003_016_samba.html
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

KINGSTON KTM5780/16G 16GB (2x8GB) 2Rx4 DDR2 PC2-5300F ECC FULLY BUFF MEMORY
$2.95
KINGSTON KTM5780/16G 16GB (2x8GB) 2Rx4 DDR2 PC2-5300F ECC FULLY BUFF MEMORY  pictureSamsung 4GB(2x2GB) 1Rx8 PC3-10600S DDR3-1333 SO-DIMM Laptop Memory
$7.99
Samsung 4GB(2x2GB) 1Rx8 PC3-10600S DDR3-1333 SO-DIMM Laptop Memory pictureMicron 16GB Kit (2X8GB) PC3L-12800 DDR3L 1600MHz SODIMM 1.35V Laptop Memory
$0.99
Micron 16GB Kit (2X8GB) PC3L-12800 DDR3L 1600MHz SODIMM 1.35V Laptop Memory pictureVisionTek 64MB Toshiba Laptop Memory Tecra 710CDT VT57025.0F
$47.5
VisionTek 64MB Toshiba Laptop Memory Tecra 710CDT VT57025.0F picture


Discussions

No Discussions have been posted on this vulnerability.