Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> SSH1 CRC-32 compensation attack


Vulnerability Assessment Details

SSH1 CRC-32 compensation attack

Vulnerability Assessment Summary
Checks for the remote SSH version

Detailed Explanation for this Vulnerability Assessment

Summary :

It is possible to execute arbitrary code on the remote host.

Description :

The remote host is running a version of SSH which is older than version 1.2.32,
or a version of OpenSSH which is older than 2.3.0.

The remote version of this software is vulnerable to a flaw known as a 'CRC-32
compensation attack' which may permit a possible hacker to gain a root shell on this
host.

Solution :

Upgrade to version 1.2.32 of SSH which solves this problem,
or to version 2.3.0 of OpenSSH

Network Security Threat Level:

Critical / CVSS Base Score : 10
(AV:R/AC:L/Au:NR/C:C/A:C/I:C/B:N)

Networks Security ID: 2347

Vulnerability Assessment Copyright: This script is Copyright (C) 2001-2006 Tenable Network Security

Cables, Connectors

YeaStar S100 S100-440 + D30 DSP VoIP SIP IP Rack PBX 100 Ext 8 FXS 8 FXO 0 GSM
$1150.0
YeaStar S100 S100-440 + D30 DSP VoIP SIP IP Rack PBX 100 Ext 8 FXS 8 FXO 0 GSM pictureCISCO SPA504G 4-LINE IP VOIP PHONE - Tested
$39.99
CISCO SPA504G 4-LINE IP VOIP PHONE - Tested pictureYeastar YST-TA1600 16 FXS Ports VoiP Gateway
$469.0
Yeastar YST-TA1600 16 FXS Ports VoiP Gateway pictureMitel 5330 IP5330 VoIP Phone Dual Mode 50005804 Black Back Lit Warranty
$67.99
Mitel 5330 IP5330 VoIP Phone Dual Mode 50005804 Black Back Lit Warranty picture


Discussions

No Discussions have been posted on this vulnerability.