Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> SSH setsid() vulnerability


Vulnerability Assessment Details

SSH setsid() vulnerability

Vulnerability Assessment Summary
Checks for the remote SSH version

Detailed Explanation for this Vulnerability Assessment

You are running a version of SSH which is older than version 3.1.5 or 3.2.2.

There is a bug in that version which may permit a user to obtain higher
rights due to a flaw in the way setsid() is used.


Solution : Upgrade to the latest version of SSH
See also : http://www.ssh.com/company/newsroom/article/286/
Network Security Threat Level: High

Networks Security ID: 6247

Vulnerability Assessment Copyright: This script is Copyright (C) 2002 Renaud Deraison

Cables, Connectors

Cisco EA6350 4-Port Gigabit Wired Router (C2921-VSEC-CUBE/K9)
$70.0
Cisco EA6350 4-Port Gigabit Wired Router (C2921-VSEC-CUBE/K9) picture 7931g unified ip phone - graphical display, speakerphone, poe, requires call
$84.59
 7931g unified ip phone - graphical display, speakerphone, poe, requires  call picture 7941g unified ip phone poe, requires callmanager
$112.8
 7941g unified ip phone poe, requires  callmanager pictureCisco-Linksys WRT54GS Wireless-G Broadband Router with SpeedBooster
$12.0
Cisco-Linksys WRT54GS Wireless-G Broadband Router with SpeedBooster picture


Discussions

No Discussions have been posted on this vulnerability.