Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Service detection >> RMI Remote Object Detection


Vulnerability Assessment Details

RMI Remote Object Detection

Vulnerability Assessment Summary
Detects a remote object

Detailed Explanation for this Vulnerability Assessment

Summary :

A Java RMI remote object is listening on the remote host.

Description :

The remote host is running a Java RMI remote object, which permits
one Java virtual machine to invoke methods on an object on another,
possibly remotely.

See also :

http://java.sun.com/products/jndi/tutorial/objects/storing/remote.html
http://java.sun.com/j2se/1.5.0/docs/guide/rmi/spec/rmiTOC.html
http://java.sun.com/j2se/1.5.0/docs/guide/rmi/spec/rmi-protocol3.html

Network Security Threat Level:

None

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

New 16GB2x8GB PC3-12800 DDR3-1600M?Hz 240pin Desktop Memory For AMD Motherboard
$26.86
New 16GB2x8GB PC3-12800 DDR3-1600M?Hz 240pin Desktop Memory For AMD Motherboard pictureNew16GB 2x8GB PC3-12800 DDR3-1600M?Hz 240pin Desktop Memory For AMD Motherboard
$26.86
New16GB 2x8GB PC3-12800 DDR3-1600M?Hz 240pin Desktop Memory For AMD Motherboard pictureNew 16GB 2x8GB PC3-12800 DDR3-1600M?Hz 240pin Desktop Memory ForAMD Motherboard
$26.86
New 16GB 2x8GB PC3-12800 DDR3-1600M?Hz 240pin Desktop Memory ForAMD Motherboard pictureNew 16GB 2x8GB PC3-12800 DDR3-1600M?Hz 240pin Desktop Memory For AMDMotherboard
$26.86
New 16GB 2x8GB PC3-12800 DDR3-1600M?Hz 240pin Desktop Memory For AMDMotherboard picture


Discussions

No Discussions have been posted on this vulnerability.