Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> PunBB < 1.2.7 Multiple Vulnerabilities


Vulnerability Assessment Details

PunBB < 1.2.7 Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks for multiple vulnerabilities in PunBB < 1.2.7

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains several PHP scripts that are prone to
SQL injection and cross-site scripting attacks.

Description :

The version of PunBB installed on the remote host suffers from several
flaws.

- Multiple SQL Injection Vulnerabilities
The application fails to adequately sanitize user-
supplied input to the 'search_id' parameter of the
'search' script as well as an unspecified parameter
in one of the admin scripts before using it in SQL
queries. The first issue can be successfully exploited
without authentication but does require that PHP's
'register_globals' setting be enabled while the
second requires a possible hacker first authenticate as an
admin or moderator.

- A Cross-Site Scripting Vulnerability
The application also does not sufficiently sanitize
input passed in 'url' BBcode tags before using it
in a post, which permits cross-site scripting
attacks such as theft of authentication cookies.

See also :

http://www.securityfocus.com/archive/1/archive/1/422088/100/0/threaded
http://www.securityfocus.com/archive/1/422267/100/0/threaded
http://www.punbb.org/changelogs/1.2.6_to_1.2.7.txt

Solution :

Upgrade to PunBB 1.2.7 or later.

Network Security Threat Level:

Low / CVSS Base Score : 2.3
(AV:R/AC:L/Au:NR/C:N/I:P/A:N/B:N)

Networks Security ID: 14806, 14808

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

Dell PowerEdge R720xd 2x E5-2670 v2 2.5GHz 10 Core 96GB 12x 1TB 7.2K SATA H710P
$5200.0
Dell PowerEdge R720xd 2x E5-2670 v2 2.5GHz 10 Core 96GB 12x 1TB 7.2K SATA H710P pictureDELL T7910 WORKSTATION TWO E5-2650LV4 1.7GHz 16GB 1TB SATA K4000
$4779.0
DELL T7910 WORKSTATION TWO E5-2650LV4 1.7GHz 16GB 1TB SATA K4000 pictureDELL T7910 WORKSTATION TWO E5-2637V3 3.5GHZ 96GB 2 X 1TB SATA K4000
$5339.0
DELL T7910 WORKSTATION TWO E5-2637V3 3.5GHZ 96GB 2 X 1TB SATA K4000 pictureDELL T7910 WORKSTATION TWO E5-2650LV3 1.8GHZ 96GB 3 X 1TB SATA K600
$4059.0
DELL T7910 WORKSTATION TWO E5-2650LV3 1.8GHZ 96GB 3 X 1TB SATA K600 picture


Discussions

No Discussions have been posted on this vulnerability.