Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> NOCC <= 1.0 Multiple Vulnerabilities


Vulnerability Assessment Details

NOCC <= 1.0 Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks for a local file include flaw in NOCC

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is affected by
multiple vulnerabilities.

Description :

The remote host is running NOCC, an open-source webmail application
written in PHP.

The installed version of NOCC is affected by a local file include flaw
because it fails to sanitize user input to the 'lang' parameter of the
'index.php' script before using it to include other PHP files.
Regardless of PHP's 'register_globals' and 'magic_quotes_gpc'
settings, an unauthenticated attacker can leverage this issue to view
arbitrary files on the remote host and possibly to execute arbitrary
PHP code in files on the affected host.

In addition, NOCC reportedly is affected by several other local and
remote file include, cross-site scripting, and information disclosure
vulnerabilities.

See also :

http://retrogod.altervista.org/noccw_10_incl_xpl.html
http://www.securityfocus.com/archive/1/425889/30/0/threaded

Solution :

Unknown at this time.

Network Security Threat Level:

High / CVSS Base Score : 7.0
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 16793

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

Intel P4 1.7 Ghz 256/400/1.75v Socket 478 CPU SL5UG
$28.5
Intel P4 1.7 Ghz 256/400/1.75v Socket 478 CPU SL5UG pictureIntel P4 2.8GHz/512/533/1.525V Socket 478 CPU SL6PF
$28.5
Intel P4 2.8GHz/512/533/1.525V Socket 478 CPU SL6PF pictureIntel P4 1.5GHZ/256/400/1.75V Socket 478 CPU SL5SX
$23.75
Intel P4 1.5GHZ/256/400/1.75V Socket 478 CPU SL5SX pictureIntel P4 Processor 3.2Ghz/2048/800/1.3V Socket 775 CPU SL7Z8
$95.0
Intel P4 Processor 3.2Ghz/2048/800/1.3V Socket 775 CPU SL7Z8 picture


Discussions

No Discussions have been posted on this vulnerability.