Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Databases >> MySQL multiple flaws (2)


Vulnerability Assessment Details

MySQL multiple flaws (2)

Vulnerability Assessment Summary
Checks for the remote MySQL version

Detailed Explanation for this Vulnerability Assessment

The remote host is running a version of the MySQL database which is
older than 4.0.21 or 3.23.59.

MySQL is a database which runs on both Linux/BSD and Windows platform.
The remote version of this software is vulnerable to specially crafted
ALTER TABLE SQL query which can be exploited to bypass some applied security
restrictions or cause a denial of service.

To exploit this flaw, a possible hacker would need the ability to execute arbitrary
SQL statements on the remote host.

Solution : Upgrade to the latest version of MySQL 3.23.59 or 4.0.21 or newer
Network Security Threat Level: Medium

Networks Security ID: 11357

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 David Maciejak

Cables, Connectors

5Pcs Serial ATA SATA 3 RAID Data HDD Hard Drive Disk Signal Cables Red 40cm EC
$2.9
5Pcs Serial ATA SATA 3 RAID Data HDD Hard Drive Disk Signal Cables Red 40cm EC pictureDELL RAID CONTROLLER H710P 1GB 6GB/S MINI MONO FOR DELL POWEREDGE R720XD N3V6G
$395.0
DELL RAID CONTROLLER H710P 1GB 6GB/S MINI MONO FOR DELL POWEREDGE R720XD N3V6G pictureLSI SAS9200-8E Dual Port External SAS/SATA 6Gbps RAID Adapter HBA
$39.99
LSI SAS9200-8E Dual Port External SAS/SATA 6Gbps RAID Adapter HBA  pictureStarTech.com Dual mSATA RAID Enclosure
$53.51
StarTech.com Dual mSATA RAID Enclosure picture


Discussions

No Discussions have been posted on this vulnerability.