Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> MyBBB rating Parameter SQL Injection Vulnerability


Vulnerability Assessment Details

MyBBB rating Parameter SQL Injection Vulnerability

Vulnerability Assessment Summary
Checks for rating parameter SQL injection vulnerability in MyBB

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP script that is prone to SQL
injection attacks.

Description :

The remote version of MyBB is prone to a SQL injection attack due to
its failure to sanitize user-supplied input to the 'rating' parameter
of the 'ratethread.php' script before using it in database queries.

See also :

http://www.s4a.cc/forum/archive/index.php/t-3953.html

Solution :

Enable PHP's 'magic_quotes_gpc' setting.

Network Security Threat Level:

Medium / CVSS Base Score : 4
(AV:R/AC:H/Au:NR/C:P/A:N/I:P/B:N)

Networks Security ID: 14786

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

1983 Atari Computer Camps 3-ring binder -EXTREMELY RARE- Atari 400/800/XL/XE
$59.99
1983 Atari Computer Camps 3-ring binder -EXTREMELY RARE- Atari 400/800/XL/XE pictureGraph It manual -great shape- 400/800/XL/XE =
$3.99
Graph It manual -great shape- 400/800/XL/XE = pictureDegas - disk and manual -great shape- for the Atari 520ST/1040ST
$6.99
Degas - disk and manual -great shape- for the Atari 520ST/1040ST pictureMad Libs version 1.0 - Original disk - Atari 520ST/1040ST/Mega/STE =
$1.29
Mad Libs version 1.0 - Original disk - Atari 520ST/1040ST/Mega/STE = picture


Discussions

No Discussions have been posted on this vulnerability.