Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Multiple vulnerabilities in phpBB 2.0.13 and older


Vulnerability Assessment Details

Multiple vulnerabilities in phpBB 2.0.13 and older

Vulnerability Assessment Summary
Checks for multiple vulnerabilities in phpBB 2.0.13 and older

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is affected by
multiple vulnerabilities.

Description :

According to its banner, the remote host is running a version of phpBB
that suffers from multiple flaws:

- A Path Disclosure Vulnerability
A remote attacker can cause phpBB to reveal its installation
path via a direct request to the script 'db/oracle.php'.

- A Cross-Site Scripting Vulnerability
The application does not properly sanitize user input before
using it in 'privmsg.php' and 'viewtopic.php'.

- A Privilege Escalation Vulnerability
In 'session.php' phpBB resets the 'user_id' value when an
autologin fails
it does not, however, reset the 'user_level'
value, which remains as the account that failed the autologin.
Since the software uses the 'user_level' parameter in some
cases to control access to privileged functionality, this flaw
permits a possible hacker to view information, and possibly even
perform tasks, normally limited to administrators.

- SQL Injection Vulnerabilities
The DLMan Pro and LinksLinks Pro mods, if installed, reportedly
fail to properly sanitize user input to the 'file_id' parameter
of the 'dlman.php' script and the 'id' parameter of the
'links.php' script respectively before using it in an SQL
query. This may permit a possible hacker to pass malicious input
to database queries.

See also :

http://archives.neohapsis.com/archives/bugtraq/2005-03/0059.html
http://archives.neohapsis.com/archives/bugtraq/2005-03/0085.html
http://archives.neohapsis.com/archives/bugtraq/2005-04/0056.html
http://archives.neohapsis.com/archives/bugtraq/2005-04/0063.html

Solution :

Upgrade to a version after phpBB 2.0.13 and disable the DLMan Pro and
LinksLinks Pro mods.

Network Security Threat Level:

Medium / CVSS Base Score : 5
(AV:R/AC:L/Au:NR/C:P/A:N/I:P/B:N)

Networks Security ID: 12736, 13028, 13030

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

COMMODORE 1571 Floppy Drive 64 128 with JiffyDOS Power Cable **WORKING**
$89.99
COMMODORE 1571 Floppy Drive 64 128 with JiffyDOS Power Cable **WORKING** pictureCommodore 64 | Bally Midway's Kickman In Box
$1.99
Commodore 64 | Bally Midway's Kickman In Box pictureCommodore Plus 4 Productivity Computer New Old Stock Complete In Original Box
$94.95
Commodore Plus 4 Productivity Computer New Old Stock Complete In Original Box pictureTimeworks Evelyn Wood Dynamic Reader C64 Commodore 64 Vintage Disk Software
$7.99
Timeworks Evelyn Wood Dynamic Reader C64 Commodore 64 Vintage Disk Software  picture


Discussions

No Discussions have been posted on this vulnerability.