Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> ModernBill 4.3.0 and older Multiple Vulnerabilities


Vulnerability Assessment Details

ModernBill 4.3.0 and older Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks for multiple vulnerabilities in ModernBill 4.3.0 and older

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that suffers from
multiple vulnerabilities.

Description :

The version of ModernBill installed on the remote host is subject to
multiple vulnerabilities :

- A Remote File Include Vulnerability
The application fails to sanitize the parameter 'DIR' before
using it in the script 'news.php'. A possible hacker can exploit
this flaw to browse or execute arbitrary files on the remote
host. Further, if PHP's 'permit_url_fopen' setting is enabled,
files to be executed can even come from a web server
under the attacker's control.

- Multiple Cross-Site Scripting Vulnerabilities
A possible hacker can inject arbitrary HTML and script code via the
parameters 'c_code' and 'aid' in the script 'orderwiz.php' in
order to steal cookie-based authentication credentials for
the remote host or launch other such attacks.

See also :

http://www.gulftech.org/?node=research&article_id=00067-04102005
http://archives.neohapsis.com/archives/bugtraq/2005-04/0129.html
http://www.moderngigabyte.com/modernbill/forums/showthread.php?t=20520

Solution :

Upgrade to ModernBill 4.3.1 or later.

Network Security Threat Level:

Medium / CVSS Base Score : 6
(AV:R/AC:H/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID: 13086, 13087, 13089

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

DELL POWEREDGE M630 E5-2637V3 3.5GHZ 32GB 2133MHZ LRDIMM 2 X 480GB SSD H730
$2049.0
DELL POWEREDGE M630 E5-2637V3 3.5GHZ 32GB 2133MHZ LRDIMM 2 X 480GB SSD H730 pictureDELL POWEREDGE M620 BLADE TWO E5-2603 1.80GHZ 128GB 2 X 600GB SSD H710
$1909.0
DELL POWEREDGE M620 BLADE TWO E5-2603 1.80GHZ 128GB 2 X 600GB SSD H710 pictureHP PROLIANT SL250S G8 LEFT SERVER TWO E5-2609 2.40GHZ 32GB 3 X 500GB SATA
$979.0
HP PROLIANT SL250S G8 LEFT SERVER TWO E5-2609 2.40GHZ 32GB 3 X 500GB SATA pictureDELL POWEREDGE M640 SERVER BLADE 2 X PLATINUM 8170 64GB 2 X 250GB SATA
$18149.0
DELL POWEREDGE M640 SERVER BLADE 2 X PLATINUM 8170 64GB 2 X 250GB SATA picture


Discussions

No Discussions have been posted on this vulnerability.