Vulnerability Assessment & Network Security Forums

If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.

Home >> Browse Vulnerability Assessment Database >> CGI abuses >> MODx < 0.9.1a Multiple Vulnerabilities

Vulnerability Assessment Details

MODx < 0.9.1a Multiple Vulnerabilities

Vulnerability Assessment Summary
Tries to exploit a XSS flaw in MODx

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP script that is susceptible to
multiple issues.

Description :

The remote host is running MODx, a content management system written
in PHP.

The version of MODx installed on the remote host fails to sanitize
input to the 'id' parameter of the 'index.php' script before using it
to generate dynamic HTML output. An unauthenticated attacker can
exploit this to inject arbitrary script and HTML into a user's

Also, the same lack of input sanitation reportedly can be leveraged to
launch directory traversal attacks against the affected application,
although exploitation may only be successful if the affected host is
running Windows and if PHP's 'magic_quotes_gpc' setting is disabled.

See also :,3982.0.html

Solution :

Upgrade to MODx version 0.9.1a or later.

Network Security Threat Level:

Medium / CVSS Base Score : 4.7

Networks Security ID: 17532, 17533

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors


No Discussions have been posted on this vulnerability.