Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2007:001: libmodplug


Vulnerability Assessment Details

MDKSA-2007:001: libmodplug

Vulnerability Assessment Summary
Check for the version of the libmodplug package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2007:001 (libmodplug).

Multiple buffer overflows in MODPlug Tracker (OpenMPT) 1.17.02.43 and
earlier and libmodplug 0.8 and earlier permit user-assisted remote
attackers to execute arbitrary code via (1) long strings in ITP files
used by the CSoundFile::ReadITProject function in soundlib/Load_it.cpp
and (2) crafted modules used by the CSoundFile::ReadSample function in
soundlib/Sndfile.cpp, as demonstrated by crafted AMF files.
Updated packages are patched to address this issue.

Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2007:001
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2007 Tenable Network Security

Cables, Connectors

Microsoft Proxy Server for Windows NT CD Backoffice
$10.95
Microsoft Proxy Server for Windows NT CD Backoffice pictureCisco N20-FAN5 V02 Fan Module for UCS 5108 Server Chassis
$59.99
Cisco N20-FAN5 V02 Fan Module for UCS 5108 Server Chassis pictureHP X-310 MediaSmart Server
$130.0
HP X-310 MediaSmart Server pictureLot of 20 x 8GB DDR2 PC2-5300F 2Rx4 ECC FBD Server memory Kingston KTH-XW667/16G
$180.0
Lot of 20 x 8GB DDR2 PC2-5300F 2Rx4 ECC FBD Server memory Kingston KTH-XW667/16G picture


Discussions

No Discussions have been posted on this vulnerability.