Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2006:114-1: libwmf


Vulnerability Assessment Details

MDKSA-2006:114-1: libwmf

Vulnerability Assessment Summary
Check for the version of the libwmf package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2006:114-1 (libwmf).



Multiple buffer overflows in the gd graphics library (libgd) 2.0.21 and

earlier may permit remote attackers to execute arbitrary code via malformed

image files that trigger the overflows due to improper calls to the gdMalloc

function. (CVE-2004-0941)



Integer overflows were reported in the GD Graphics Library (libgd)

2.0.28, and possibly other versions. These overflows permit remote

attackers to cause a denial of service and possibly execute arbitrary

code via PNG image files with large image rows values that lead to a

heap-based buffer overflow in the gdImageCreateFromPngCtx() function.

Libwmf contains an embedded copy of the GD library code. (CVE-2004-0990)



Update:



The previous update incorrectly attributed the advisory text to

CVE-2004-0941, while it should have been CVE-2004-0990. Additional

review of the code found fixes for CVE-2004-0941 were missing and have

also been included in this update.



Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2006:114-1
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

Dell PowerEdge T630 - 2x 8 Core E5-2630 v3 2.4GHz/ 32GB RAM/ 5x 1TB SAS HDD
$5469.0
Dell PowerEdge T630 - 2x 8 Core E5-2630 v3 2.4GHz/ 32GB RAM/ 5x 1TB SAS HDD pictureDell PowerEdge T630 - 2x 8 Core E5-2630 v3 2.4GHz/ 16GB RAM/ 5x 300GB SAS HDD
$5209.0
Dell PowerEdge T630 - 2x 8 Core E5-2630 v3 2.4GHz/ 16GB RAM/ 5x 300GB SAS HDD pictureDell PowerEdge R730 2x E5-2620v3 2.4GHz 6 Core 128GB 8x 900GB 10K SAS H730 RAID
$4825.0
Dell PowerEdge R730 2x E5-2620v3 2.4GHz 6 Core 128GB 8x 900GB 10K SAS H730 RAID pictureDell PowerEdge R630 2x E5-2660v3 2.6GHz 10 Core 256GB 8x R-Series Tray PERC H730
$5550.0
Dell PowerEdge R630 2x E5-2660v3 2.6GHz 10 Core 256GB 8x R-Series Tray PERC H730 picture


Discussions

No Discussions have been posted on this vulnerability.