Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2005:209: fetchmail


Vulnerability Assessment Details

MDKSA-2005:209: fetchmail

Vulnerability Assessment Summary
Check for the version of the fetchmail package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2005:209 (fetchmail).



Thomas Wolff and Miloslav Trmac discovered a race condition in the
fetchmailconf program. fetchmailconf would create the initial output
configuration file with insecure permissions and only after writing would it
change permissions to be more restrictive. During that time, passwords and
other data could be exposed to other users on the system unless the user used a
more restrictive umask setting. As well, the Mandriva Linux 2006 packages did
not contain the patch that corrected the issues fixed in MDKSA-2005:126, namely
a buffer overflow in fetchmail's POP3 client (CVE-2005-2355). The updated
packages have been patched to address this issue, and the Mandriva 2006
packages have also been patched to correct CVE-2005-2355.



Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2005:209
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

DELL POWEREDGE R730 16 BAY E5-2687WV3 3.1GHZ 16GB 8 X 1TB SATA H730
$4359.0
DELL POWEREDGE R730 16 BAY E5-2687WV3 3.1GHZ 16GB 8 X 1TB SATA H730 pictureHP Z820 WORKSTATION W7 PRO TWO E5-2650LV2 1.70GHZ 128GB 2 X 1TB SATA NVS310 512M
$4789.0
HP Z820 WORKSTATION W7 PRO TWO E5-2650LV2 1.70GHZ 128GB 2 X 1TB SATA NVS310 512M pictureHP Z440 WORKSTATION W7 PRO E5-1620V4 3.5GHZ 128GB 1TB SSD QUADRO M2000 4GB
$3629.0
HP Z440 WORKSTATION W7 PRO E5-1620V4 3.5GHZ 128GB 1TB SSD QUADRO M2000 4GB picture


Discussions

No Discussions have been posted on this vulnerability.