Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2005:118: ruby


Vulnerability Assessment Details

MDKSA-2005:118: ruby

Vulnerability Assessment Summary
Check for the version of the ruby package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2005:118 (ruby).



A vulnerability was discovered in ruby version 1.8 that could permit for the
execution of arbitrary commands on a server running the ruby xmlrpc server.

The updated packages have been patched to address this issue.



Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2005:118
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

IBM RAID CONTROLLER MAGARAID SAS 8880EM2 8 PORT 3Gb/S PCI-E X8 43W4337
$222.0
IBM RAID CONTROLLER MAGARAID SAS 8880EM2 8 PORT 3Gb/S PCI-E X8 43W4337 pictureIBM RAID MEMORY MODULE 256MB WITH OPTION TO CONNECT BATTERY BACKED 25R8075
$29.0
IBM RAID MEMORY MODULE 256MB WITH OPTION TO CONNECT BATTERY BACKED 25R8075 pictureFUJITSU MEGARAID LSI 2008 6GB/S PCI-E 2.0 X8 RAID CONTROLLER D2607-A21-HIGH P
$149.0
FUJITSU MEGARAID LSI 2008 6GB/S PCI-E 2.0 X8 RAID CONTROLLER D2607-A21-HIGH P pictureIBM SERVERAID BR10I PCI-E X8 RAID CONTROLLER 44E8689-NO BRACKET
$155.0
IBM SERVERAID BR10I PCI-E X8 RAID CONTROLLER 44E8689-NO BRACKET picture


Discussions

No Discussions have been posted on this vulnerability.