Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2005:109: php-pear


Vulnerability Assessment Details

MDKSA-2005:109: php-pear

Vulnerability Assessment Summary
Check for the version of the php-pear package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2005:109 (php-pear).



A vulnerability was discovered by GulfTech Security in the PHP XML RPC project.
This vulnerability is considered critical and can lead to remote code
execution. The vulnerability also exists in the PEAR XMLRPC implementation.

Mandriva ships with the PEAR XMLRPC implementation and it has been patched to
correct this problem. It is advised that users examine the PHP applications
they have installed on their servers for any applications that may come bundled
with their own copies of the PEAR system and either patch RPC.php or use the
system PEAR (found in /usr/share/pear).

Updates have been released for some popular PHP applications such as WordPress
and Serendipity and users are urged to take all precautions to protect their
systems from attack and/or defacement by upgrading their applications from the
authors of the respective applications.



Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2005:109
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

LOT OF 12 IBM 2TB 7.2K 3.5" SAS Server Hard Drive Caddy Tray 95310-06 0970658-04
$59.95
LOT OF 12 IBM 2TB 7.2K 3.5IBM SYSTEM X3550 M2 SERVER E5506 2.13GHZ 8GB 1TB SAS
$469.0
IBM SYSTEM X3550 M2 SERVER E5506 2.13GHZ 8GB 1TB SAS pictureIBM SYSTEM X3650 M4 2.5 SERVER E5-2670 2.6GHZ 32GB 7 X 600GB 10K SAS M5110E
$2509.0
IBM SYSTEM X3650 M4 2.5 SERVER E5-2670 2.6GHZ 32GB 7 X 600GB 10K SAS M5110E pictureIBM 90Y8890, 90Y8891, 90Y8894 - 600GB 10k SAS 2.5 HDD - New Server Hard Drive
$80.0
IBM 90Y8890, 90Y8891, 90Y8894 - 600GB 10k SAS 2.5 HDD - New Server Hard Drive picture


Discussions

No Discussions have been posted on this vulnerability.