Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2005:093: postgresql


Vulnerability Assessment Details

MDKSA-2005:093: postgresql

Vulnerability Assessment Summary
Check for the version of the postgresql package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2005:093 (postgresql).



A number of vulnerabilities were found and corrected in the PostgreSQL DBMS:

Two serious security errors have been found in PostgreSQL 7.3 and newer
releases. These errors at least permit an unprivileged database user to crash
the backend process, and may make it possible for an unprivileged user to gain
the rights of a database superuser.

Functions that support client-to-server character set conversion can be called
from SQL commands by unprivileged users, but these functions are not designed
to be safe against malicious choices of argument values. (CVE-2005-1409)

The contrib/tsearch2 module misdeclares several functions as returning type
'internal' when they do not have any 'internal' argument. This breaks the type
safety of 'internal' by permiting users to construct SQL commands that invoke
other functions accepting 'internal' arguments. (CVE-2005-1410)

These vulnerabilities must also be fixed in all existing databases when
upgrading. The post-installation script of the updated postgresql-server
package attempts to do this automatically.

The updated packages have been patched to correct these problems.



Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2005:093
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 Tenable Network Security

Cables, Connectors

Cisco 7940 Series CP-7940G VoIP PoE Business Phone w/ Handset and AC adapter
$26.17
Cisco 7940 Series CP-7940G VoIP PoE Business Phone w/ Handset and AC adapter pictureNEW Obihai OBi200 VoIP Telephone Adapter with Google Voice SIP 1-Phone Port USB
$9.99
NEW Obihai OBi200 VoIP Telephone Adapter with Google Voice SIP 1-Phone Port USB picture"Obihai OBi200 1-Port VoIP Adapter with Google Voice and Fax Support for Home...
$55.32
SHORETEL IP 530 VOIP Phone S2 IP530 Black - NIB
$41.79
SHORETEL IP 530 VOIP Phone S2 IP530 Black - NIB picture


Discussions

No Discussions have been posted on this vulnerability.