Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2004:159: glibc


Vulnerability Assessment Details

MDKSA-2004:159: glibc

Vulnerability Assessment Summary
Check for the version of the glibc package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2004:159 (glibc).



The Trustix developers discovered that the catchsegv and glibcbug utilities,
part of the glibc package, created temporary files in an insecure manner. This
could permit for a symlink attack to create or overwrite arbitrary files with
the rights of the user invoking the program.

The updated packages have been patched to correct this issue.



Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2004:159
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Cisco Xfinity XB3 Telephony WiFi Modem Router DOCSIS 3.0 DPC3939 - Tested
$42.5
Cisco Xfinity XB3 Telephony WiFi Modem Router DOCSIS 3.0  DPC3939 - Tested  pictureCisco Catalyst WS-C2960S-48FPS-L Ethernet Switch w/STACK 15.0 IOS 1-YR Warranty
$599.95
Cisco Catalyst WS-C2960S-48FPS-L Ethernet Switch w/STACK 15.0 IOS 1-YR Warranty pictureCisco LINKSYS 4-Port Gigabit Wireless N Router WRVS4400N
$9.99
Cisco LINKSYS   4-Port Gigabit Wireless N Router  WRVS4400N pictureCISCO WS-C2960-48TC-L 48 PORT NETWORK SWITCH LANBASE TESTED SKU144967
$79.98
CISCO WS-C2960-48TC-L 48 PORT NETWORK SWITCH LANBASE TESTED SKU144967 picture


Discussions

No Discussions have been posted on this vulnerability.