Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2004:158: samba


Vulnerability Assessment Details

MDKSA-2004:158: samba

Vulnerability Assessment Summary
Check for the version of the samba package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2004:158 (samba).



Remote exploitation of an integer overflow vulnerability in the smbd daemon
included in Samba 2.0.x, Samba 2.2.x, and Samba 3.0.x prior to and including
3.0.9 could permit a possible hacker to cause controllable heap corruption, leading to
execution of arbitrary commands with root rights. In order to exploit this
vulnerability a possible hacker must possess credentials that permit access to a share
on the Samba server. Unsuccessful exploitation attempts will cause the process
serving the request to crash with signal 11, and may leave evidence of an
attack in logs. The updated packages have been patched to correct this issue.



Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2004:158
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

IBM 174724X-B99 IBM IBM System Storage EXP2524 Express Storage Enclosure (No Rai
$267.0
IBM 174724X-B99 IBM IBM System Storage EXP2524 Express Storage Enclosure (No Rai pictureIBM 7870B3U-C15 IBM.Server BladeCenter HS22 Xeon Quad-Core 2.40 GHz Bus Speed: 5
$147.0
IBM 7870B3U-C15 IBM.Server BladeCenter HS22 Xeon Quad-Core 2.40 GHz Bus Speed: 5 pictureIBM 7870AC1-C146 IBM.Server BladeCenter HS22 2 x Xeon Quad-Core 2.53 GHz Bus Spe
$125.0
IBM 7870AC1-C146 IBM.Server BladeCenter HS22 2 x Xeon Quad-Core 2.53 GHz Bus Spe pictureIBM 7870AC1-C144 IBM.Server BladeCenter HS22 2 x Xeon Quad-Core 2.93 GHz Bus Spe
$125.0
IBM 7870AC1-C144 IBM.Server BladeCenter HS22 2 x Xeon Quad-Core 2.93 GHz Bus Spe picture


Discussions

No Discussions have been posted on this vulnerability.