Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2004:142: gzip


Vulnerability Assessment Details

MDKSA-2004:142: gzip

Vulnerability Assessment Summary
Check for the version of the gzip package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2004:142 (gzip).

The Trustix developers found some insecure temporary file creation problems in
the zdiff, znew, and gzeze supplemental scripts in the gzip package. These
flaws could permit local users to overwrite files via a symlink attack.
A similar problem was fixed last year (CVE-2003-0367) in which this same
problem was found in znew. At that time, Mandrakesoft also used mktemp to
correct the problems in gzexe. This update uses mktemp to handle temporary
files in the zdiff script.

Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2004:142
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

Seagate ST3600057SS 9FN066-038 NA03 600GB 15.7K 3.5" SAS HDD IBM
$23.0
Seagate ST3600057SS 9FN066-038 NA03 600GB 15.7K 3.5HPE 300GB 10K Hot Swap DP 2.5 SFF SAS 507284-001
$59.0
HPE 300GB 10K  Hot Swap DP 2.5 SFF SAS 507284-001 pictureApple Mac Pro A1289 Desktop - MB535LL/A 8 Core, 8GB Ram, 1.5TB Hard Drive
$399.0
Apple Mac Pro A1289 Desktop - MB535LL/A 8 Core, 8GB Ram, 1.5TB Hard Drive pictureSanDisk X300 512GB Internal 2.5" (SD7SB7S-512G-1122) SSD
$47.0
SanDisk X300 512GB Internal 2.5


Discussions

No Discussions have been posted on this vulnerability.