Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2004:120: mpg123


Vulnerability Assessment Details

MDKSA-2004:120: mpg123

Vulnerability Assessment Summary
Check for the version of the mpg123 package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2004:120 (mpg123).



Carlos Barros discovered two buffer overflow vulnerabilities in mpg123
the
first in the getauthfromURL() function and the second in the http_open()
function. These vulnerabilities could be exploited to possibly execute
arbitrary code with the rights of the user running mpg123.

The provided packages are patched to fix these issues, as well additional
boundary checks that were lacking have been included (thanks to the Gentoo
Linux Sound Team for these additional fixes).



Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2004:120
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Lenovo ThinkPad E560 15.6-Inch Laptop Intel Core i5-6200U 8GB RAM 500GB HD
$329.99
Lenovo ThinkPad E560 15.6-Inch Laptop Intel Core i5-6200U 8GB RAM 500GB HD  pictureOpen-Box Certified: HP - 15.6" Laptop - Intel Core i5 - 8GB Memory - 1TB Hard...
$424.99
Open-Box Certified: HP - 15.6Lenovo X230 12.5" Touch Tablet Laptop Core i5-3320M 2.6GHz 8GB 160GB SSD Win 10
$299.99
Lenovo X230 12.5HP Pavilion 15-AB243CL 15.6" Laptop Intel Core Windows 8
$58.0
HP Pavilion 15-AB243CL 15.6


Discussions

No Discussions have been posted on this vulnerability.