Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2004:112: squid


Vulnerability Assessment Details

MDKSA-2004:112: squid

Vulnerability Assessment Summary
Check for the version of the squid package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2004:112 (squid).


iDEFENSE discovered a Denial of Service vulnerability in squid version
2.5.STABLE6 and previous. The problem is due to an ASN1 parsing error where
certain header length combinations can slip through the validations performed by
the ASN1 parser, leading to the server assuming there is heap corruption or some
other exceptional condition, and closing all current connections then
restarting.
Squid 2.5.STABLE7 has been released to address this issue
the provided packages
are patched to fix the issue.


Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2004:112
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Lot of 2 8gb (16gb) PC3-10600R Hynix Server Memory ECC Registered
$40.0
Lot of 2 8gb (16gb) PC3-10600R Hynix Server Memory ECC Registered pictureDell PowerEdge R910 Server X7560 4x 2.26GHz 40-Core Working
$86.28
Dell PowerEdge R910 Server X7560 4x 2.26GHz 40-Core Working  pictureHynix 48GB (12X4GB) PC3-10600R DDR3 1333MHz ECC Reg HMT151R7TFR4C-H9 D7 Server
$70.0
Hynix 48GB (12X4GB) PC3-10600R DDR3 1333MHz ECC Reg HMT151R7TFR4C-H9 D7 Server picture


Discussions

No Discussions have been posted on this vulnerability.