Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2004:092: samba


Vulnerability Assessment Details

MDKSA-2004:092: samba

Vulnerability Assessment Summary
Check for the version of the samba package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2004:092 (samba).


Two vulnerabilities were discovered in samba 3.0.x
the first is a defect in
smbd's ASN.1 parsing that permits a possible hacker to send a specially crafted packet
during the authentication request which will send the newly spawned smbd process
into an infinite loop. As a result, it is possible to use up all available
memory on the server.
The second vulnerability is in nmbd's processing of mailslot packets which could
permit a possible hacker to anonymously crash nmbd.
The provided packages are patched to protect against these two vulnerabilities.


Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2004:092
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Avago AFBR-720XPDZ 10G-XFP-SR SFP
$11.71
Avago AFBR-720XPDZ 10G-XFP-SR SFP pictureCISCO 37-0890-01 1 Meter Blade switch Server SFP Stacking Cable MOLEX 74577-0051
$27.32
CISCO 37-0890-01 1 Meter Blade switch Server SFP Stacking Cable MOLEX 74577-0051 pictureHP ProCurve 10G SFP+ XCVR LR ER Optical Fibre Transceiver J9153A Retail WTY
$3600.0
HP ProCurve 10G SFP+ XCVR LR ER Optical Fibre Transceiver J9153A Retail WTY pictureLot of 3 Genicom SRX-SFP-1GE-LX 1000BLX Mini-GBIC Compatible w/Juniper
$48.0
Lot of 3 Genicom SRX-SFP-1GE-LX 1000BLX Mini-GBIC Compatible w/Juniper picture


Discussions

No Discussions have been posted on this vulnerability.