Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2003:082: php


Vulnerability Assessment Details

MDKSA-2003:082: php

Vulnerability Assessment Summary
Check for the version of the php package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2003:082 (php).


A vulnerability was discovered in the transparent session ID support in PHP4
prior to version 4.3.2. It did not properly escape user- supplied input prior to
inserting it in the generated web page. This could be exploited by a possible hacker
to execute embedded scripts within the context of the generated HTML
(CVE-2003-0442).
As well, two vulnerabilities had not been patched in the PHP packages included
with Mandrake Linux 8.2: The mail() function did not filter ASCII control
filters from its arguments, which could permit a possible hacker to modify the mail
message content (CVE-2002-0986). Another vulnerability in the mail() function
would permit a remote attacker to bypass safe mode restrictions and modify the
command line arguments passed to the MTA in the fifth argument (CVE-2002-0985).
All users are encouraged to upgrade to these patched packages.


Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2003:082
Network Security Threat Level: High

Networks Security ID: 5562, 5681, 7761

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

507610-B21 508009-001 HP 500GB 6G SAS 7.KK 2.5" Mid Line Hard Drive
$150.0
507610-B21 508009-001 HP 500GB 6G SAS 7.KK 2.5Linksys SRW2016 ver 1.3 16-Port 10/100/1000 Gigabit Switch with WebView
$29.99
Linksys SRW2016 ver 1.3 16-Port 10/100/1000 Gigabit Switch with WebView picture752368-081 HP 8GB 1Rx4 PC4-2133P ECC REG Memory 774170-001 726718-B21
$140.0
752368-081 HP 8GB 1Rx4 PC4-2133P ECC REG Memory 774170-001 726718-B21 pictureHP E2620-24 PoE+ Switch | J9625A
$37.0
HP E2620-24 PoE+ Switch | J9625A picture


Discussions

No Discussions have been posted on this vulnerability.