Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2003:050: apache2


Vulnerability Assessment Details

MDKSA-2003:050: apache2

Vulnerability Assessment Summary
Check for the version of the apache2 package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2003:050 (apache2).


A memory leak was discovered in Apache 2.0 through 2.0.44 that can permit a
remote attacker to cause a significant denial of service (DoS) by sending
requests containing a lot of linefeed characters to the server.
As well, Apache does not filter terminal escape sequences from its log files,
which could make it easy for a possible hacker to insert those sequences into the
error and access logs, which could possibly be viewed by certain terminal
emulators with vulnerabilities related to escape sequences.
After upgrading these packages, be sure to restart the httpd server by
executing:
service httpd restart


Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2003:050
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Low Profile Raid Controller Server Card Bracket Bezel
$5.95
Low Profile Raid Controller Server Card Bracket Bezel pictureSAS9260-8I Kit Raid 8PORT Int 6GB Sas/sata Pcie 2.0 512MB
$256.47
SAS9260-8I Kit Raid 8PORT Int 6GB Sas/sata Pcie 2.0 512MB pictureGlyph Studio RAID 2TB Desktop Hard Drive
$279.95
Glyph Studio RAID 2TB Desktop Hard Drive pictureHP P410 512MB 462919-001 Smart Array SAS RAID Controller Card BBWC PCIe Card
$9.84
HP P410 512MB 462919-001 Smart Array SAS RAID Controller Card BBWC PCIe Card picture


Discussions

No Discussions have been posted on this vulnerability.