Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2003:049-1: kde3


Vulnerability Assessment Details

MDKSA-2003:049-1: kde3

Vulnerability Assessment Summary
Check for the version of the kde3 package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2003:049-1 (kde3).


A vulnerability was discovered by the KDE team in the way that KDE uses
Ghostscript for processing PostScript and PDF files. A malicious attacker could
provide a carefully constructed PDF or PostScript file to an end user (via web
or mail) that could lead to the execution of arbitrary commands as the user
viewing the file. The vulnerability can be triggered even by the browser
generating a directory listing with thumbnails.
All users are encouraged to upgrade to these new kdegraphics, kdebase, and
kdelibs packages that contain patches to correct the problem. This issue is
corrected upstream in KDE 3.0.5b and KDE 3.1.1a.
Update:
The previous update was missing a fix in kdebase specific to HP machines. This
has been corrected.


Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2003:049-1
Network Security Threat Level: High

Networks Security ID: 7318

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Seagate 1TB Desktop HDD SATA 6Gb/s 64MB Cache 3.5-Inch Internal Bare Drive
$29.5
Seagate 1TB Desktop HDD SATA 6Gb/s 64MB Cache 3.5-Inch Internal Bare Drive  pictureDell PowerEdge R410 2x X5550 2.66GHz Quad Core 16GB 4x 1TB 7.2K SATA PERC 6/i
$605.0
Dell PowerEdge R410 2x X5550 2.66GHz Quad Core 16GB 4x 1TB 7.2K SATA PERC 6/i pictureHP Z820 WORKSTATION W7 PRO TWO E5-2695V2 2.40GHZ 256GB 4 X 1TB SATA NVS310 512MB
$6559.0
HP Z820 WORKSTATION W7 PRO TWO E5-2695V2 2.40GHZ 256GB 4 X 1TB SATA NVS310 512MB pictureDELL T7810 WORKSTATION E5-2698V3 2.3GHZ 16GB 2 X 1TB SATA 4000
$4639.0
DELL T7810 WORKSTATION E5-2698V3 2.3GHZ 16GB 2 X 1TB SATA 4000 picture


Discussions

No Discussions have been posted on this vulnerability.