Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2003:043-1: krb5


Vulnerability Assessment Details

MDKSA-2003:043-1: krb5

Vulnerability Assessment Summary
Check for the version of the krb5 package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2003:043-1 (krb5).


Multiple vulnerabilties have been found in the Kerberos network authentication
system. The MIT Kerberos team have released an advisory detailing these
vulnerabilties, a description of which follows.
An integer signedness error in the ASN.1 decoder before version 1.2.5 permits
remote attackers to cause a crash of the server via a large unsigned data
element length, which is later used as a negative value (CVE-2002-0036).
Mandrake Linux 9.0+ is not affected by this problem.
Vulnerabilties have been found in the RPC library used by the kadmin service. A
faulty length check in the RPC library exposes kadmind to an integer overflow
which can be used to crash kadmind (CVE-2003-0028).
The KDC (Key Distribution Center) before version 1.2.5 permits remote,
authenticated attackers to cause a crash on KDCs within the same realm using a
certain protocol that causes a null dereference (CVE-2003-0058). Mandrake Linux
9.0+ is not affected by this problem.
Users from one realm can impersonate users in other realms that have the same
inter-realm keys due to a vulnerability in Kerberos 1.2.3 and earlier
(CVE-2003-0059). Mandrake Linux 9.0+ is not affected by this problem.
The KDC permits remote, authenticated users to cause a crash on KDCs within the
same realm using a certain protocol request that causes an out-of-bounds read of
an array (CVE-2003-0072).
The KDC permits remote, authenticated users to cause a crash on KDCs within the
same realm using a certain protocol request that causes the KDC to corrupt its
heap (CVE-2003-0082).
Vulnerabilities have been discovered in the Kerberos IV authentication protocol
which permit a possible hacker with knowledge of a cross-realm key, which is shared in
another realm, to impersonate a principle in that realm to any service in that
realm. This vulnerability can only be closed by disabling cross-realm
authentication in Kerberos IV (CVE-2003-0138).
Vulnerabilities have been discovered in the support for triple-DES keys in the
Kerberos IV authentication protocol which is included in MIT Kerberos
(CVE-2003-0139).
MandrakeSoft encourages all users to upgrade to these updated packages
immediately which contain patches to correct all of the previously noted
vulnerabilities. These packages also disable Kerberos IV cross-realm
authentication by default.
Update:
The packages for Mandrake Linux 9.1 and 9.1/PPC were not GPG-signed. This has
been fixed and as a result the md5sums have changed. Thanks to Mark Lyda for
pointing this out.


Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2003:043-1
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

DELL A2360P-00 Blade Server 2360W Power Supply PSU
$44.99
DELL  A2360P-00 Blade Server 2360W Power Supply PSU picture32 G  ( 4x 8Gb ) DELL SNPTJ1DYC/8G 8GB DDR3 PC3-10600R DIMM Server
$80.0
32 G  ( 4x 8Gb ) DELL SNPTJ1DYC/8G  8GB DDR3 PC3-10600R DIMM Server   pictureDell T3500 Workstation PC Case w/ PSU +
$31.29
Dell T3500 Workstation PC Case w/ PSU + picture(Lot of 2) Dell E1100E-S0 0YT39Y / 1100W Server Power Supplies
$49.95
(Lot of 2) Dell E1100E-S0 0YT39Y / 1100W Server Power Supplies picture


Discussions

No Discussions have been posted on this vulnerability.