Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2003:004-1: kde


Vulnerability Assessment Details

MDKSA-2003:004-1: kde

Vulnerability Assessment Summary
Check for the version of the kde package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2003:004-1 (kde).


Multiple instances of improperly quoted shell command execution exist in KDE 2.x
up to and including KDE 3.0.5. KDE fails to properly quote parameters of
instructions passed to the shell for execution. These parameters may contain
data such as filenames, URLs, email address, and so forth
this data may be
provided remotely to a victim via email, web pages, files on a network
filesystem, or other untrusted sources.
It is possible for arbitrary command execution on a vulnerable system with the
rights of the victim's account.
The code audit by the KDE team resulted in patches for KDE 2.2.2 and KDE 3

version 3.0.5a was released and the KDE team encourages the upgrade. The listed
KDE2 packages have the KDE team's patches applied to provide the fixed code.
Update:
The SRPM for the new arts for Mandrake Linux 9.0 was not linked into the updates
tree. This has been corrected.


Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2003:004-1
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Lenovo Ideapad 320-15IAP 15.6" TOUCH SCREEN USED
$150.0
Lenovo Ideapad 320-15IAP 15.6Samsung 960 EVO Internal SSD 250GB V-NAND M.2 2280 PCIe (MZ-V6E250BW) #EB12878
$39.97
Samsung 960 EVO Internal SSD 250GB V-NAND M.2 2280 PCIe (MZ-V6E250BW) #EB12878 pictureASUS GL503 Rog STRIX 17.3in Intel Core i7-7th Gen 16GB RAM 1TB RAM+128GB SSD
$800.0
ASUS GL503 Rog STRIX 17.3in Intel Core i7-7th Gen 16GB RAM 1TB RAM+128GB SSD picture


Discussions

No Discussions have been posted on this vulnerability.