Vulnerability Assessment & Network Security Forums
If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important. If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.
Vulnerability Assessment Details
Check for the version of the openssh package
Detailed Explanation for this Vulnerability Assessment
The remote host is missing the patch for the advisory MDKSA-2002:040-1 (openssh).
An input validation error exists in the OpenSSH server between versions 2.3.1
and 3.3 that can result in an integer overflow and privilege escalation. This
error is found in the PAMAuthenticationViaKbdInt code in versions 2.3.1 to 3.3,
and the ChallengeResponseAuthentication code in versions 2.9.9 to 3.3. OpenSSH
3.4 and later are not affected, and OpenSSH 3.2 and later prevent privilege
escalation if UsePrivilegeSeparation is enabled
in OpenSSH 3.3 and higher this
is the default behaviour of OpenSSH.
To protect yourself, users should be using OpenSSH 3.3 with
UsePrivilegeSeparation enabled (see MDKSA:2002-040). However, it is highly
recommended that all Mandrake Linux users upgrade to version 3.4 which corrects
There are a few caveats with this upgrade, however, that users should be aware
- On Linux kernel 2.2 (the default for Mandrake Linux 7.x), the use of
Compression and UsePrivilegeSeparation are mutually exclusive. You can use one
feature or the other, not both
we recommend disabling Compression and using
privsep until this can be resolved.
- Using privsep may cause some PAM modules which expect to run with root
privilege to fail. For instance, users will not be able to change their password
if they attempt to log into an account with an expired password.
If you absolutely must use one of these features that conflict with privsep, you
can disable it in /etc/ssh/sshd_config by using:
However, if you do this, be sure you are running OpenSSH 3.4. Updates to OpenSSH
will be made available once these problems are resolved.
Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2002:040-1
Network Security Threat Level: High
Networks Security ID:
Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security
|Vintage DEC Digital RF71 400MB Hard Drive Option RF71-EA
|Digital DEC VT320 ANSI Computer Terminal, Vintage 1988, No Keyboard. VT-320
|DEC LSI-11 PDP-11/03 ORIGINAL VINTAGE COMPUTER USERS MANUAL
|DEC M8310 MAJOR REGISTER CONTROL BD PDP VINTAGE COMPUTER
No Discussions have been posted on this vulnerability.