Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2002:026: libsafe


Vulnerability Assessment Details

MDKSA-2002:026: libsafe

Vulnerability Assessment Summary
Check for the version of the libsafe package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2002:026 (libsafe).


Wojciech Purczynski discovered that format string protection in libsafe can be
easily bypassed by using flag characters that are implemented in glibc but are
not implemented in libsafe. It was also discovered that *printf function
wrappers incorrectly parse argument indexing in format strings, making some
incorrect assumptions on the number of arguments and conversion specifications.
These problems were fixed by the libsafe authors in 2.0-12.


Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2002:026
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

HP 72GB 10K SAS 2.5inch HDD w/Caddy 375863-008 430165-002 ST973402SS
$14.95
HP 72GB 10K SAS 2.5inch HDD w/Caddy 375863-008 430165-002 ST973402SS pictureHP 376596-001 36GB SAS HARD DRIVES 10K RPM 2.5" 394924-001 375863-003 w/ caddy
$10.0
HP 376596-001 36GB SAS HARD DRIVES 10K RPM 2.5Seagate 1200.2 St400fm0303 400 Gb 2.5" Internal Solid State Drive - Sas
$953.37
Seagate 1200.2 St400fm0303 400 Gb 2.5Western Digital 160GB WD Scorpio 2.5" Internal Hard Drive HDD WD1600BEVT
$7.51
Western Digital 160GB WD Scorpio 2.5


Discussions

No Discussions have been posted on this vulnerability.