Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2002:007: at


Vulnerability Assessment Details

MDKSA-2002:007: at

Vulnerability Assessment Summary
Check for the version of the at package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2002:007 (at).


zen-parse discovered a problem in the at command containing an extra call to
free() which can lead to a segfault with a carefully crafted, but incorrect,
format. This is caused due to a heap corruption that can be exploited under
certain circumstances because the at command is installed setuid root. Thanks to
SuSE for an additional security improvement that ads the O_EXCL (exclusive)
option to the open(2) system call inside the at code.


Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2002:007
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Cisco CP-7925G Genuine Extended Battery P/N 74-5469-01 1400mAh VOIP Phone
$24.95
Cisco CP-7925G Genuine Extended Battery P/N 74-5469-01 1400mAh VOIP Phone picture5-Line IP Phone with Color Dis - VoIP
$277.0
5-Line IP Phone with Color Dis - VoIP pictureCisco SPA504G 4-Line Display IP Phone - Tested/Working - Grade A/B+ PoE VoIP
$45.0
Cisco SPA504G 4-Line Display IP Phone - Tested/Working - Grade A/B+ PoE VoIP pictureObihai OBI100 VoIP Telephone Adapter with Power Adapter
$12.0
Obihai OBI100 VoIP Telephone Adapter with Power Adapter picture


Discussions

No Discussions have been posted on this vulnerability.