Vulnerability Assessment & Network Security Forums

If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.

Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2001:077-1: apache

Vulnerability Assessment Details

MDKSA-2001:077-1: apache

Vulnerability Assessment Summary
Check for the version of the apache package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2001:077-1 (apache).

A problem exists with all Apache servers prior to version 1.3.19. The
vulnerablity could permit directory indexing and path discovery on the vulnerable
servers with a custom crafted request consisting of a long path name created
artificially by using numerous slashes. This can cause modules to misbehave and
return a listing of the directory contents by avoiding the error page.
Another vulnerability found by Procheckup ( was that all
directories, by default, were configured as browseable so a possible hacker could list
all files in the targeted directories. As well, Procheckup found that the
perl-proxy/management software on port 8200 would supply dangerous information
to attackers due to a perl status script that was enabled. We have disabled
directory browsing by default and have disabled the perl status scripts.
The previous updates for 7.2 had some problems with mod_perl segfaulting and
with mod_ssl under 7.1. As well, ApacheJServ was not included for 7.2 and 8.0.
Other security fixes were introduced in Apache 1.3.22. A vulnerability in the
split-logfile support program would permit any file with a .log extension on the
system to be written to due to a specially crafted Host: header.
This update provides Apache 1.3.22 for all supported platforms, and the packages
for 7.1, 7.2, and Corporate Server 1.0.1 now use the same modular design as 8.0
and later versions. You will be unable to safely upgrade these packages and will
need to take a few very important manual steps to ensure a proper upgrade (this
is only applicable to 7.2 and earlier distributions
this is not required for
8.0 and later):
1) Stop apache (service httpd stop) 2) Completely backup /etc/httpd/conf/* 3)
Backup /var/log/httpd (the uninstall scripts of the previous apache versions may
remove the log files) 4) Remove the currently installed apache, mod_perl,
mod_ssl, and php packages from the system. You can do this using:
urpme apache
urpme php
or (if you are using 7.2):
urpme apache-common
urpme php
5) Upgrade mm/mm-devel and (if you are upgrading 7.1 or Corporate Server) the
new perl packages 6) Install the download upgrade packages of apache components
using 'rpm -ivh *.rpm' 7) Restore your /var/log/httpd backup 8) Merge your
configuration backups with the new config files (most notably you will need to
edit commonhttpd.conf) 9) Start apache (service httpd start)
This update also introduces PHP 4.0.6 to Linux-Mandrake 7.1, 7.2, and Corporate

Solution :
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

DREVO X1 PRO 512GB SSD TLC SATA III 2.5" 6Gbps Internal Solid State Drive for PC
672756-001 HP Original SPS-DRIVE SSD 256GB SED  pictureDell EqualLogic 200GB SAS 2.5" 6G MLC Solid State Drive SSD LB206M with Caddy
Dell EqualLogic 200GB SAS 2.5StarTech 3.5in Drive Bay IDE to Single CF SSD Adapter Card Reader 35BAYCF2IDE
StarTech 3.5in Drive Bay IDE to Single CF SSD Adapter Card Reader 35BAYCF2IDE picture


No Discussions have been posted on this vulnerability.