Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Mandrake Local Security Checks >> MDKSA-2001:062: samba


Vulnerability Assessment Details

MDKSA-2001:062: samba

Vulnerability Assessment Summary
Check for the version of the samba package

Detailed Explanation for this Vulnerability Assessment

The remote host is missing the patch for the advisory MDKSA-2001:062 (samba).


Michal Zalewski has found a vulnerability in all versions of Samba prior to
2.0.10 where if a client sends an invalid netbios name Samba could be tricked
into appending it's log to files writable by root. This can be very dangerous if
combined with a symlink created by a local user. Note that the log files must be
specified as %m.log in order for this to work, and Mandrake Linux ships Samba by
default using log.%m, thus it is not vulnerable 'out of the box'.


Solution : http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2001:062
Network Security Threat Level: High

Networks Security ID:

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

USED Cisco C2960S-STACK 2960S FlexStack Stack Module optional for LAN Base
$349.77
USED Cisco C2960S-STACK 2960S FlexStack Stack Module optional for LAN Base pictureNetgear FE516 16 Port 100 Base-Tx Fast Ethernet Hub Switch 10/100Mbps Networks
$3.78
Netgear FE516 16 Port 100 Base-Tx Fast Ethernet Hub Switch 10/100Mbps Networks pictureBrocade SilkWorm 7500 16-Port Fibre Channel Switch w/ 15x SFP 80-1000552-01
$499.95
Brocade SilkWorm 7500 16-Port Fibre Channel Switch w/ 15x SFP 80-1000552-01 pictureJ9729A HP PROCURVE SWITCH 2920 48G POE+
$859.99
J9729A HP PROCURVE SWITCH 2920 48G POE+ picture


Discussions

No Discussions have been posted on this vulnerability.